BUG: Clone Brewery to a place doesn't appear to work

I’ve tried a couple of times now for Evolution brewing and Severance in Sioux Falls but neither appears to work.
I’m using Chrome on my Dell laptop if that helps work out what is going on.

It’s been bought back onto the pages but doesn’t work

Do you see this option on the new brewers page? I don’t.

For the old brewers page it works for me but almost everytime the created place lands in the middle of the ocean and needs to be manually located by an admin.

Yes, on the brewers pages. Just nothing happens!

Clicked once on the CLONE BREWERY button from the new page and it worked form me…

However, you always need to edit it afterwards because the geolocation info is left empty so it won’t appear on the map if you don’t manually input it.

Well I’ve tried it several times and nothing happens.

I’ve checked that the place hasn’t been created as well.

Is it set for super admin?

Just tried again with Evolution Beer Co in Shrewsbury in the UK

I get the logo then nothing, refreshed the page and no associated place appears.

Searched Evolution Beer and 5 returns and not that one. Either it’s going into the ether or it isn’t working.

I’d already manually added this place and rated it so had to nuke your creation.

Thanks for creating though!

@services please bring this function back

It’s back since a year ago, the geolocation is bugged on cloning resulting on the Place not appearing at all on the map (empty coordinates)