RateBeer Forums

BUG New Places/Beers/Breweries don't appear in Search and City Maps / Indexing bug (re-emerged 2019-06-07)

All Beers / Brewers / Places entered since a few days ago don’t appear in Search Result and the new places don’t appear on the map on the city page…
Same with edits, if you edit the name, the search return the product with the old name, not the edited name…

The database indexing for new products and for recent changes is not working well.

I just created this place.

https://www.ratebeer.com/p/la-station-eastman/86192/

I can see it from the City Page but if I click on the map from the city page, it’s not there.

However, I can see it on the map if I click on the expander from the Place page.

Also if I search for the place, it doesn’t appear in the search result (suggesting it might not detect the distance)

I tried fixing geolocation manually but it didn’t change anything…

I added a new place today. Same problem. The Place doesn’t appear in the the map from the City map link.

It just appear from the map expander in the Place Page.
and it doesn’t appear in the search results either.
https://www.ratebeer.com/p/brasserie-wilsy/86218/

This seems like a server problem because I update the name of the brewer as well and in the search results, it still display the name before it had before I updated it…

Same thing happens for new beers. They can’t be found using the search…


Is the ElasticSearch indexing not running?

Just added a few new places and doesn’t appear on the main map but when I go tot he brewery place it does appear on the mini map when I expand it. An example:

https://www.ratebeer.com/beermap?p=86197&z=15

Not sure if this is related but also places that I have recently closed are still showing on all the searches and the maps.

All Beers / Brewers / Places entered since a few days ago don’t appear in Search Result and the new places don’t appear on the map on the city page…
Same with edits, if you edit the name, the search return the product with the old name, not the edited name…

The database indexing for new products and for recent changes is not working well.

@joet @services

Guys it’s been more than 4 days like this…can you fix this?

@joet @services

I’ve added a few breweries and beers but not rated them yet, now they don’t show up when I search.

They do appear on the counties brewery list and the beers show on the brewery page. And example is the Uppingham a new brewery in Rutland, and their beer UB1.

@joet @services

Is there any progress to resolve this problem? More than a week that new entries and edits are not working in the search engine
Also the new entries and edits are not updated in the map too…

@joet @services

We are expecting a fix very soon. I’ll be testing later.

1 Like

Hi everyone, we have re-indexed the affected beers, brewers and places, so new entries should all be searchable now. Please let us know if you continue to see any issues searching for new beers, brewers, places.

3 Likes

I edited those places name and added a picture more than 1 week ago and they are still not up to date in the search (picture ok, name wrong) and in the map (name wrong, no picture). They are showing somehow correctly on their own page (no picture, name ok) and in the city page.

@Viper666 is this still the case? It’s appearing fine for me.

Yep, still the same as of right now.

You may just need to power reload?

@joet It does the same thing with the App, in Mozilla Browser and in Chrome Browser…

And the logo is there on the website but they don’t appear on the App for whatever reason…(normally, it’s the contrary, they appear instantly on the App and takes 2-3 days before it displays on the website…)

Is anyone else seeing the same kind of behavior for these places?

@joet @Viper666

The pic is everywhere now - that’s probably a cache issue on Viper’s side since he added it.

However, the name’s wrong in the search and on the maps (says Dépanneur while it shouldn’t).