BUG Search is still broken with special characters

Can someone tell me how I can find this place L’Espace Public - Brasseurs de Quartier using the current search (web and mobile app) other than finding it from the brewer’s page link.

Even if I write the exact name L’Espace Public - Brasseurs de Quartier I get no result.

For other places like Saint-Houblon (Quartier Latin) and Saint-Houblon (Côte-des-Neiges), I manage to find them using the search only if I write sainthoublon but I get no result if I write Saint-Houblon or Saint Houblon but lespace public, espacepublic or lespacepublic is not working for the other one…

That character problem seems to be fixed for beers and brewers search but is still problematic with places.

Oh I managed to find it…it works if (and only if) I write espace public … because espace brasseur or even brasseur de quartier is not even working

I searched your link and I reckon that it worked for me. Samsung Galaxy S8. Using Chrome. Shrugs.

As I said, it works to find the Brewer, but not the Place. I’m having this problem using the Android app, Chrome mobile and Firefox 64 on windows10 desktop…

I copied L’Espace Public - Brasseurs de Quartier and pasted in the search on the beer page.

Yeah, searching for the place yields nothing as I don’t even get a “go” or magnifying glass.

Why is it listed as a brewer and a place? Sounds conflicting to me and maybe the website

Because a single brewer may have more than one affiliated places. And some brewers don’t have affiliated places at all.
Just for example, Saint-Houblon is a brewer located in Terrebonne, Canada
and their brewery is not opened to the public.

But the brewer owns 2 restaurants located in Montreal, Canada where you can find their beers.
Both those places are “associated” with the Brewer.

1 Like

@Viper666.Qc looks like this has been fixed right?

1 Like


Confirmed - on all the examples. Closing this out.

Don’t close it too fast buddy! The L’ problem isn’t fully resolved yet.

Try writing “amère à boire” or “amere a boire”. I get 1 beer result, no brewer, no place result.
but you should be able to see all thing related to this brewery Brasserie “Artisanale L’Amère à Boire”

Try writing “Octant”. You should see all things related to “L’Octant - Microbrasserie” in first place but only the Place comes first, the brewery shows after many Ocean title brewery and no beer result.

However, it works if I use “lamere” or “loctant”

@tjbiddle @joet @services

Thanks so much for this quality bug report. Love the snaps and specific examples.

This is a complex issue we’re currently working through now. We’re looking to balance our firepower with user needs and it’s important for us to see where search fails. So this is not a quick switch sort of fix unfortunately, but it is something we’re again discussing.

We looked at how search works now and saw how partial search is working to show targets pretty well even if they aren’t the top result. For now we’ll have no changes. If this becomes a greater need or we find an opportunity to improve, we’ll definitely do so.

Now also broken with regular characters.
Simple search like borg +enter and wolla !!

Sounds like a broken record but “have you tried to log out and back in again”?

Nope, just used borg as an sample. Been going on whole day.
Search for i.e. Hansa give same result.

and this one I get when I klick on a beer in my Beer rating list:

Maybe it is about time to move on to somthing more stable than RB.
To bad because the DB is more detaljed and better in many ways than some other alternatives, but seriously I am getting tired.
This demolition of RB has been going on for too long now. When will they realise that fancy is not always equal good functionality and usefull.


This is a local cache issue; logging out and back in again should fix it. You can discuss any other issues relating to this bug over here: BUG Network Error problems

still some problem for names preceded by “L’” that show no result
orée du bois or oree du bois no result

L’Orée du bois, lorée du bois and loree du bois shows all results…