RateBeer Forums

FIXED App crashes everytime I hit the search button

For at least the past week, maybe longer, the app crashes everytime i hit the search button, or the search option when scanning bar codes. Very annoying, and having to use the website on the phone us not optimal. Anybody else having this?

Once you scanned a product, and then search a product, the app crashes in the current version.

You have to select a recently searched product and click reject (reject adding the code bar). Then it should stop crashing.

Don’t use the scanner for the moment, they said they would fix it in the next release.

1 Like

Lol you guys are using the app?

Why won’t you use it? it works correctly now (for the most part :wink: )

The app is one of the main reasons why I still use ratebeer. It usually works fine and has most of the functions I need.

I can confirm this bug as well. The app is unusable at the moment for me. If I click the search button or UPC scan it crashes.

download the latest available version (I’m at Android 2.6.8 but I’m Beta tester…so maybe the live version still has the bug)
@services

I’ve just pushed the Android version of 2.6.8 live, there is still an issue with Apple, so working through that.

Android at least should be available in the next hour or so.

Regards,
Services @ RateBeer

Alright, Im dumb. Google Play still has 2.6.6. Is there somewhere else to get the newer version?

@stevoj 2.6.8 should be available on Google Play soon… takes a few hours to propagate.

Regards,
Services @ RateBeer

What is the status of the Apple version bug fix? I am on 2.6.6 and did have the app crash when searching after a scan.

@voyageurmike

We’re just currently working through an issue that Apple raised at the moment with them. Once that’s sorted I should have a better ETA on the next Apple release.

Regards,
Services @ RateBeer

Uninstalled and reinstalled and that solved my issue. Not sure what the previous version was but could have been out of date.

I take it back. It only solved the issue until I closed the app and opened it again later. Now it is back to the previous bug where it crashes when I touch the search icon.

@cavie

What version of the App are you running and what OS?

Regards,
Services @ RateBeer

App version 2.6.6
iOS 13.7

@Cavie

Thanks, iOS hasn’t been updated yet, Apple has a few issues with the latest release and I’m just working through them with Apple.

Will let you know when a build will be available with that fixed.

Regards,
Services @ RateBeer

Eh, no worries. I only drink at home now-adays so the desktop is always there. Plus with iOS 14 coming out next week I figured a new app version would be in the pipeline anyway.
Thanks for working on it.

@Cavie

2.6.9 has just been released, it should hopefully solve your issue!

Regards,
Services @ RateBeer

I had to do a complete delete and reload app to my phone as this was happening on iOS 13.7. Seemed to be fine after the reload.

I see iOS 14 is released or releasing, will see how that turns out.





Add To RateBeer

Add A Beer
Add A Brewer
Add A Place
Add An Event


Manage Your Account

Add Premium
Edit Profile
Messages
Sign out

RateBeer Newsletter

Subscribe to our newsletter, RateBeer Weekly, a must for understanding new people, places and beers in worldwide craft culture.


Stay Connected


2000- 2017 © RateBeer, LLC. All Rights Reserved. Privacy Policy | Terms of Service