RateBeer Forums

Places maps broken


#1

https://www.ratebeer.com/beermap?p=0&z=13&lt=5155419&ln=-25719

giving for development purposes only

Was opk abotu an hour or 2 back


Place Maps Not Working
#2

Google changed their pricing model for maps back in June and has been rolling them out since.

They now require an API otherwise you will reach the For Development Purposes Only error when the set quota has been exceeded.

https://developers.google.com/maps/faq#api-key-billing-errors


#3

what’s all that mean for us? The maps were one of the most useful aspects of the site for me. @joet


#4

I would suspect that RateBeer needs to get an API, which comes with some (28.000) monthly dynamic map loads, and more for static maps.

Or find another map source, such as OpenStreetMap, that allows free use, or download and host free maps on their own server.


#5

Bump @joet

Should we take up a collection? Go Fund Me.


#6

No need for a funding
I renewed my Premium, it works again !
Good News at last !:sunglasses:


#7

Oh yeak looks fixed. excellent , just in time for final trip planning


#8

Still doesn’t work for me…


#9

BUMS. back to be ing broken @services @joet


#10

But… on the “development only” map at least I can see where the place markers are :smiling_imp:


Maps disappeared?
#11

Can someone provide a URL/link to how you got to this page?


#12

I just noticed it now, maybe I haven’t used much the maps in the past days; this should show you:
https://www.ratebeer.com/beermap?p=32141

And this is how it looks like:

Joe, I don’t know if you can do anything, but these place markers are really hard to glance in an urban environment, unless we already know what/where we are looking for.
Often other map details (restaurants, attractions, parks…) are slightly more visible than the Place markers.
I think that switching to a marker without the donut hole would improve the visibility.


#13

Thanks for the great quality feedback! It’s much appreciated. i was hoping to push a fixed map with today’s updates but the problem with maps is not so trivial. Instead of just adding our API key, we need to make additional code changes.

I’ll check into updating the markers to the google default.


#14

how strange. This was back to normal for at least a day and no longer. Strange. What’s happening behind the curtain?


#15

I’m no expert here, but maybe the explanation is in AndySnow’s post, above;
it doesn’t seem that our code is broken, more like we exceeded some usage limit.
Maybe somebody has the time and will to read the link…


#16

Toto is slacking


#17

Still no places map working for me.

Any ETA on a fix for this ? @Joet @services


#18

fixed?


#19

Maps are working for me. Miracles do happen. :slight_smile:


#20

Working for me now.

And i see this after i returned back from my place ticking tour of Paris!

Well hopefully it will work tomorrow aswell.