RateBeer Forums

SOLVED BUG App Search function

#1

I can’t get the app to search for beers. It just gives me the red oops message every time. Anyone else?

#2

No problem for me. iPhone 6S running App Version 1.16.0

Now that said, one problem with the search box that I have been having is that if I search a beer and then tap the x to erase the search, it does not erase what I have typed and simply changes the x into a barcode scanner. I’ve been having that issue for some time.

#3

log out, log in again?

The only bug I get recently with the app is when I switch between apps and then go back to the app, I sometimes gets a “No Connection error” in red. I most close the app and open it again, then I get “you are now Connected” in green and can resume.

Oh and if you open you gps after you open the app, it won’t find anything nearby. Thenn again, you close the app, open it again and then the nearby function works again.

#4

I don’t have that problem (last version android), when I do so, the search bar goes empty with the scanner at the end, with the 3 most recent searches under, Nearby places and recently viewed beers after

#5

Hmm. I deleted and downloaded the app, still can’t use the search function.

#6

Can you please post a full bug report in the mobile app bug forum? Include reproducible steps, as well as any screenshots and explanation.

#7

I logged out and it fixed the problem it seems. Odd that actually deleting the app didn’t do it. Not sure who moved this thread though.

#8

I believe our mobile engineers fixed this last week - I actually hit it as well, I believe it was due to having tried a new library. Anyone still running into this?

#9

Our mobile engineer identified that it is due to an old login token. If you logged in once a year ago, you will encounter this bug a fix has been put in place to resolve this moving forward.

1 Like
closed #10