RateBeer Forums

SOLVED - BUG Edits to rating score and availability not saved

#1

When I try to edit a non-qualified rating to a valid rating, it does save the text I enter, but fails to save the edits I made to the scores and availability. I have to edit my edited rating in order to get these saved. Please look into this.
I’ve added (most of) the non-qualified ratings through the app, and edited them on the website, where the scores are pre-filled.

3 Likes

#3

Am I the only one experiencing this problem? @joet @services?
This issue happens when I rate with the slider in the app, and want to update to a valid rating later on my laptop. If I pre-fill the attribute scores in the app, I don’t have the problem, but that would defeat the purpose of a quick rate imho. This would mean for me that I stop using the app, as it’s the only reason I use it at the moment.

1 Like

#4

So it sounds like you are doing this

  1. You quick-rate on mobile app entering a total score and fewer than 75 characters
  2. You then attempt to edit the rating using the web app by entering more than 75 characters, adding attribute scores and availability information
  3. Then you click save and observe that only the text has saved and not the attribute scores, nor availability information

Is that correct?

0 Likes

#5

Yes, that’s correct, if by web app you mean on a web browser on a laptop.
I only enter a total score on the mobile app, no characters, no attribute scores.

1 Like

#6

I get the same problem. I can quick rate (tick) using the slider and on the app or mobile web but I can only save availability with the app, not mobile web.

1 Like

#7

Same problem here. I just detected it and this sucks highly! I tick all the beers I buy and put in the cellar. Then I go back and rate them. I just now detected that this doesnt save my score edits. I must have put a good amount of wrong reviews in now and cant trace them back.

@joet merry christmas, but get this site to work again! This sucks extremely, now even my ratings are save anymore.

1 Like

#8

So, I thought to fill in at least the attribute scores with the app, but that means you can’t edit the beer later on mobile through a web browser. It needs to be done through the app or on a desktop. On purpose?

EDIT: you can’t edit on a desktop when you pre-filled the attribute scores in the app. You just get a blank page.

1 Like

#9

Yeah for the moment, you have to do it with the app, but at least it works well now.,

0 Likes

#10

It doesn’t work well on a desktop computer. I use the app for a quick rate, and then update on a desktop. but because the app pre-fills the attribute scores, on a desktop I have to edit the rating I just edited before everything is like I think it should be. Highly annoying and time-consuming.

0 Likes

#11

Ok I thought you meant by Quick Rating to attribute the 5-point score (AATPO) using the App

0 Likes

#12

Nope, only the final score

0 Likes

#13

Thank you all for your alertness, patience and detailed feedback. We’ve recently issued a fix. Cheers!

@Borresteijn @Viper666 @rhoihessegold

1 Like

#14

Hi @joet, thanks, this saves us a lot of time. While this is now fixed, it still seems impossible to edit a private rating, e.g. a rating made in the app with attribute scores added, on a desktop or web browser.

0 Likes

#15

Still some bugs left there.

For example, I “quick rated” a beer using the app and added availability, but there’s no way I can edit it further on desktop because the three dots sends me to an empty white page if I click Edit (see top left)

If I didn’t add availability, I could edit it by clicking the Rate & Review bar like this one

@joet

and there’s still no way to see our 5 point attributes scores with ratings without characters…

0 Likes

#16

the problem might be related to the bottle/can/tap/cask availability because when it’s not selected, I can still edit it with the Rate & Review bar even if I previously added Place availability

@joet

(you should also add Growler/Crowler, Nitro/Creamer in availability…

0 Likes

#17

It’s not just the availability, but also the attribute scores.

0 Likes

#18

You’re right…once I changed the Attribute scores, I can’t edit it anymore, with or without availability.

0 Likes

#19

@joet I’m still not able to edit private ratings, made with the app, on a desktop. It gives me a blank page. It’s only possible through the mobile app, and I’d really like to be able to do so on a laptop.

0 Likes

#20

Hi everyone, we think that this bug has now been fixed – sorry that it took us a while to fix this one, but we wanted to fix the root cause. Please let us know if you still see any issues here

1 Like

#21

Appears to be fixed indeed. Will keep you posted in case I overlooked something.

0 Likes