Cant add beer ratings

bug

Reproduction Steps

-Start filling all info for rating

  • click submit
    • loading starts
    • getting error Error submitting review. Please try again

From the server just:

        {
            "message": "An internal server error has occurred.",
            "name": "INTERNAL_SERVER_ERROR",
            "time_thrown": "2024-07-03T13:55:57.887Z",
            "data": {
                "uuid": "f93cacf0-3943-11ef-a910-2d82c17e2e5f"
            }
        }
    ],
    "data": {
        "userReview": null
    }
}

Seems not working at least for the past hour for me, tried other beer just in case and did not work either. Clearing cookies did not help.

System Information

On chrome, windows 10

3 Likes

I’m also having trouble. Is this the end? I hit save rating and it won’t do it on Microsoft edge (I haven’t been able to sign into RB on Chrome for months). Is the end nigh?

1 Like

I was having the same problem so I logged out and then signed back in using this legacy address:

https://www.ratebeer.com/places/addaplace.asp

Then everything seemed to work OK again. I hope this helps.

1 Like

I had mentioned this the other day. Thought maybe it was just me but apparently not.
It’s taken me 5 to 7 submissions sometimes but they’ve eventually made it through. Getting worse maybe??

3 Likes

just tried again, did not work from Chrome but suddenly worked from edge once, but stopped working a bit later
For me one in 20 submits/edits maybe work on edge.

1 Like

I’m trying on Chrome & Firefox tonight, can’t log a thing.

Edit: managed to log a beer eventually.
Logged the beer rating, saved
Added the description, saved
Added ‘served in’ & location, saved

What a faff

1 Like

Using a chromebook while on vakay. Worked quickly & took the rating first time. Not sure what’s going on. I did have trouble, but logged out and logged back in with the legacy page and its OK now.

I’m really concerned about the continued usability of this site. I better download my ratings, if that’s still possible.

1 Like

The good old way worked.Log out and then log in with add place its work for me.

2 Likes

Having intermittent problems on my phone - went on holiday without a laptop. Paste into notes in case it doesn’t go through the first couple of attempts.

3 Likes

I have for avile must rate the same beer 3-4 times before it worked.

1 Like

The site is being worked on again, finally, and I’m chalking this bloody annoyance up to that (no people accidentally DDOS-ing the site by mass entering ratings by script, like a few months back, hah).

You might have noticed some small changes and fixes recently, small ones, but we’re technically in the best spot we’ve been in for a while now. It’s probably gonna suck here and there, and the lack of wider transparency and forewarning sucks as well, but there we are.

Now let’s hope that the major issues are resolved ASAP.

11 Likes

fingers crossed

1 Like

Well!?!?

1 Like

Not working at all for me today. Even after logging out and in again via Add New Place

2 Likes

Tried like 20 times to add a review. “Error submitting review. Please try again.” is all I get.

2 Likes

And yeah, I also tried logging out then in via “Add New Place.”

2 Likes

Few tips from someone who rates more than most folks and therefore spots patterns/habits with tech issues.

Logging in and out again makes no difference … the site is either playing up or behaving.

It worked fine today from approx 1200 to 1730 UK time.

When it stops letting you add rates this tends to last (typically … don’t fucken quote me on shit) for 1 to 2 hours then it’s fine again and rates will go flying in.

7 Likes

Well, I’m gonnah give it a try pretty soon.

Like marko said “The site is being worked on again, finally, and I’m chalking this bloody annoyance up to that” - I hope this problem is due to somebody working on the chronic bugs.

1 Like

Go now !

Just read your post then all of a sudden a rate went through, so I simply hit submit on the 5 other windows I had open that were stuck and they all flew through … so a downtime there of perhaps 1 hour 15 mins?

3 Likes

Working fine again here as well.

3 Likes