Logging into ratebeer.com

Is anybody else having issues today with logging into the ratebeer.com or the RateBeer.com -- Login?

I can access the forums but not the legacy website.

Can someone confirm this problem or is it on my end? I tried 2 different computers and browsers.

Yup me too. On my laptop, I can do forums, can’t login to the regular site to rate beers or add beers, no matter if I login using places etc or any other way. I use chrome.

On my phone it’s the opposite. I can get into the site to rate beers using phone browser, but can’t get into the forums.

1 Like

Thanks! I thought I was having a personal computer problem. I bet the apple stuff is immune to this.

edit: Well, just tried my iphone, can’t log in on it either.

looks like its working now!

1 Like

I was going to say start with clearing cache and cookies for the RB with no RB tabs open. Then try the log in trick with places. If it still persist let us know what operating systems and search engine.

Let me know @solidfunk if you are still having issues and I will reach out to @joet

Ya, uggh, I hate clearing cookies, logs me out of a million things. I will try that when I have some time

It wasn’t a cookie problem.

You should be able to select just RateBeer items hopefully.


I can still rate beers and see the forums but can’t see stats or tags or various other things (notably download my ratings) - I get the robot. I would try the old page “add a place” link, but I get the robot there too. Going to my profile takes me to a page that appears to be logged out but if I select a beer I appear not to be logged out.

More pages get the robot now, including looking at my profile page or beers rated. I have cleared cookies (Firefox) and tried to log in via the old add places link.

Have you rated a beer with special characters, I’ve seen this cause robot on at least the latest activity screen.

1 Like

I’ve rated a Kölsch - style, a beer with a ! in its name and with a % in its name in my last 50. [edit: and now I can see them, a couple of apostrophes and a Fantôme] Could be part of it. Earlier I was able to see my profile page but it looked like it I wasn’t logged in, then if I clicked on a beer I appeared to be logged in again. I’ll try clearing cookies again.

1 Like

Got worse again - tried clearing cookies and logging in the old way but get the robot for profile, styles and am logged out in the forums. I’m posting this on my phone - can still use the forums in Safari.

Happy to hear suggestions because the site is no longer useable apart from me adding beers.

Sad to hear. Were you ever connected to a brewery or place and then disconnected?

Mailing Joe so he can see if there’s some issue with your profile.

Important questions:
-were all tabs with RB in your browser closed when you went to clear site data and cookies? None should be open when you’re doing it.
-Did you clear site data and cookies or just cookies?
-Does it happen on other browsers on your PC?

Sorry if you answered that previously, just want to have everything in one places

Thanks Marko.

I’ve never been associated with a brewery or place.

I’ve tried things on a few browsers. I’m posting this on Safari on my phone, where I continue to be able to see and post to the forums.

In Firefox (usual browser) I closed all tabs and logged out before clearing cookies and site data and restarting the browser. I also tried doing this in Chrome and Edge before reopening Firefox and trying the legacy login.

I did this because last time I tried Edge I got a new message after a few cycles login attempts saying I should log out of all browsers on my device. So I think I’ve cleared cookies and data. I also usually use Privacy Badger but have it switched off for the site.

The behaviour seems the same: after clearing cookies I can login using the legacy login but then I get the robot when I click profile or my beer ratings, styles, countries etc. Search works fine and I can add a beer but NOT a brewery (which is a shame because I would have been able to rate a beer from a brewery with no ratings on unTappd, but alas had to rate it there only).

If I then open the forums I am actually not logged in ( rather than just looking like it).

Then if I log in there I can see the forums but clicking RateBeer logs me out of the legacy login and I can’t log back in again either way without clearing cookies and data.

Until recently I could see a stranger’s view of my profile page but no longer. Indeed I can’t see any user’s profile page.

One weird detail- my profile pic is of an old single (record). Sometimes it appears centred but mostly off centre with a black crescent at the top.

1 Like

This is odd, if everything’s fine with the account (haven’t checked if Jote answered this morning), we might have to look into other options, including the possibility of Privacy Badger (or something else!) somehow still killing your tokens. Or some other plugin messing with it (if there are any). Hm.

The issue seems similar to what @Theydon_Bois was experiencing - basically a side-effect of some bug that split his acc.

1 Like

I think you replied while I was adding another chunk of text. The last bit - the odd variation in profile pic - does seem consistent with the “split account somehow” idea.

Hmm, we might need to find the other part then…

Just for an FYI, this issue above was resolved. :slight_smile:

Anyone else experiencing it?

1 Like