This Place Sucks

For real.

I’m logged on on my phone. But I can’t figure out how to log in on my laptop. Except I’m logged on like halfway on my laptop because I can see my beers that I’ve rated before.

The split in old website and new website is fucken unnavigable unless you’re one of the nerds that’s just on here every fucken day. I can’t figure it out.

I get that nothing will get updated anymore because we got sold to Budweiser or whatever, but can we at least keep the base level functionality without fuxking shot up? Fuck you.


^^^ buzzed quick

But seriously I can’t make any shit work.

Please help me.

See here:

Is Bud still in the picture? I thought they bailed on us to??

I shouldn’t have to solve a fucken riddle to log in to a website, which I already seem to be logged in to twice.

Work around is pinned at the top of forum ffs! This is what happens when we lose dedicated tech support two years ago, but people starting new threads weekly complaining has sure sped up @joet finding someone to fix it. :man_facepalming:t3:

1 Like

Yes, you shouldn’t. Yes, it’s a known issue, yes there’s a work-around which could’ve been found by taking a better look at the forums before posting, no searching needed even.

It’s extremely annoying, it’s as far as we’re informed in the process of being resolved, and I’m pissed off that it wasn’t resolved yet - but there was seemingly an objective reason why it wasn’t.

This place is basically the Purdue of beer rating websites. Sad!

1 Like

Sorry I didn’t read every post in an 80 post thread to figure out how the website was broken.

1 Like

This is the problem I’m having. Is there a work around for this?

We’ve begat to our kids Buffalo Bills and Purdue football fandom. Please pray for them.

1 Like

The first one would’ve sufficed for pretty much everyone. I see no reason to open yet another dramatic thread about the same subject handled elsewhere. We are all on the edge, no need to add fuel to the fire.

1 Like

Which browser, which device? Tried clearing cache & cookies (making sure no tab with RB was open)?

If you need some beers added till it’s resolved, by all means point me/us towards them and they will be added.

1 Like

Sorry if my post is clogging up all of the rousing discussion that goes on here.


I forgive you.

1 Like

Oh look, sarcasm, cute, here’s a like. Anyway, did what I suggested help, or can we help you with adding the beers that need to be added, and can you and @b3shine (if he’s still experiencing it) please provide the info I requested so that we can try to replicate it and inform the only person that might be able to resolve it with concrete information about a potential other aspect of the bug / a potential additional bug?

I answered half of your question in my original post in the other thread, but no one took the time to reply to it. The answer to the other half of your question is Chrome, which has never been an issue on my PC prior to reporting it. And no, what you suggested didn’t help. I had tried that prior to posting.

Thank you! I won’t apologize for myself, as I had absolutely no extra time to take with all I’m doing, but that does indeed suck. And not happening on latest Chrome for me either, weirdly. Does the issue happen when you try to add beers through the brewery page, or add a beer on the bottom or both?


Don’t get too worked up, Marko. Nobody cares about this site anymore other than as a repository for their scoops.